Excel: SI.ERROR (función SI.ERROR)


error1

En este artículo, se describen la sintaxis de la fórmula y el uso de la función (función: fórmula ya escrita que toma un valor o valores, realiza una operación y devuelve un valor o valores. Utilice funciones para simplificar y acortar fórmulas en una hoja de cálculo, especialmente aquellas que llevan a cabo cálculos prolongados o complejos.)SI.ERROR en Microsoft Excel.

Descripción

Devuelve un valor que se especifica si una fórmula se evalúa como un error; de lo contrario, devuelve el resultado de la fórmula. Utilice la función SI.ERROR para interceptar y controlar errores en una fórmula (fórmula: secuencia de valores, referencias de celda, nombres, funciones u operadores de una celda que producen juntos un valor nuevo. Una formula comienza siempre con el signo igual (=).).

error2

 

Sintaxis

SI.ERROR(valor; valor_si_error)

La sintaxis de la función SI.ERROR tiene los siguientes argumentos (argumento: valor que proporciona información a una acción, un evento, un método, una propiedad, una función o un procedimiento.):

  • Valor Obligatorio. El argumento en el que se busca un error.
  • Valor_si_error Obligatorio. El valor que se devuelve si la fórmula se evalúa como un error. Se evalúan los tipos siguientes de error: #N/A, #¡VALOR!, #¡REF!, #¡DIV/0!, #¡NUM!, #¿NOMBRE? o #¡NULO!.

Observaciones

  • Si valor o valor_si_error están en una celda vacía, SI.ERROR los trata como un valor de cadena vacía (“”).
  • Si valor es una fórmula de matriz, SI.ERROR devuelve una matriz de resultados para cada celda del rango especificado en el valor. Vea el segundo ejemplo siguiente.

error3

 

Ejemplos

Ejemplo: Interceptar errores de división utilizando una fórmula regular

El ejemplo será más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo copio un ejemplo?

  • Seleccione el ejemplo de este artículo.

Importante No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  • Presione CTRL+C.
  • En Excel, cree una hoja de cálculo o un libro en blanco.
  • En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

Importante Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  • Para cambiar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione Alt+º, o en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.

 

 
1
2
3
4
5

6

7

8

A B
Cuota Unidades vendidas
210 35
55 0
  23
Fórmula Descripción (resultado)
=SI.ERROR(A2/B2; “Error en el cálculo”) Comprueba si hay un error en la fórmula en el primer argumento (divide 210 por 35), no encuentra ningún error y devuelve los resultados de la fórmula (6).
=SI.ERROR(A3/B3; “Error en el cálculo”) Comprueba si hay un error en la fórmula en el primer argumento (divide 55 por 0), encuentra un error de división por 0 y devuelve valor_si_error (Error en el cálculo).
=SI.ERROR(A4/B4; “Error en el cálculo”) Comprueba si hay un error en la fórmula en el primer argumento (divide “” por 23), no encuentra ningún error y devuelve los resultados de la fórmula (0).

Ejemplo: Interceptar errores de división utilizando una fórmula de matriz

El ejemplo será más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo copio un ejemplo?

  • Seleccione el ejemplo de este artículo.

Importante No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  • Presione CTRL+C.
  • En Excel, cree una hoja de cálculo o un libro en blanco.
  • En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

Importante Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  • Para cambiar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione Alt+º, o en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.

 

 
1
2
3
4
5
6
7
8
A B C
Cuota Unidades vendidas Relación
210 35 =SI.ERROR(A2:A4/B2:B4; “Error en el cálculo”)
55 0  
  23  
Fórmula Descripción (resultado)  
=C2 Comprueba si hay un error en la fórmula en el primer argumento del primer elemento de la matriz (A2/B2 o divide 210 por 35), no encuentra ningún error y devuelve los resultados de la fórmula (6).  
=C3 Comprueba si hay un error en la fórmula en el primer argumento del segundo elemento de la matriz (A3/B3 o divide 55 por 0), encuentra un error de división por 0 y devuelve valor_si_error (Error en el cálculo).  
=C4 Comprueba si hay un error en la fórmula en el primer argumento del tercer elemento de la matriz (A4/B4 o divide “” por 23), no encuentra ningún error y devuelve los resultados de la fórmula (0).  

 Nota La fórmula del ejemplo debe especificarse como fórmula de matriz. Después de copiar el ejemplo en una hoja de cálculo en blanco, seleccione el rango C2:C4, presione F2 y, a continuación, presione CTRL+MAYÚS+ENTRAR.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s